Peculiar Message on SQL Compare

This just started happening.  Just wondering how I can get rid of it. 

I've tried connecting both the source and target databases to source control and looking for a migration script, but one doesn't exist.  I believe I'm going to need to go outside the GUI on this one.
Tagged:

Best Answer

Answers

  • @KathyG - your screenshot references a feature that has since been deprecated. Are you using the "migrations" feature from SQL Source Control? If not, then edit your SQL Compare options and set the Behavior to "Ignore migration scripts for databases", which should make the message go away.

    (If you are using the migration scripts feature in SQL Source Control, we have a better alternative, which I'd be happy to provide more detail on if needed)
    David Atkinson
    Product Manager
    Redgate Software
  • KathyGKathyG Posts: 18 Bronze 1
    Thank you David,

    I followed your instructions, saved the options change, closed down SQL Compare then restarted it.

    Unfortunately, there is no behavior change.

  • @KathyG
    I've checked with the dev team and the SQL Compare option is referencing an older version of the migrations feature. Sorry about the confusion.

    If you rename (or remove, if you're definitely not using the migrations feature) the RedGateLocal schema in your database, and SQL Compare will no longer raise the error message.

    Can you confirm if you are using the migrations feature? It could be that the schema is there because you tried the feature in the past, and you're no longer using it, in which case it's safe to remove. If you are using it, then it's something we're recommending strongly to move away from (we have an improved version).
    David Atkinson
    Product Manager
    Redgate Software
  • KathyGKathyG Posts: 18 Bronze 1
    Nope, we don't use this feature.  Now, there was a migrations database that was accidentally created and I deleted it (the database only).  I'm thinking that's the source of the problem but I can't figure out where to go to fix it (I thought deleting the database would fix it).  Maybe there's a config file somewhere?  As you can see from the last pic I sent the Ignore option has been checked.
  • David AtkinsonDavid Atkinson Posts: 1,384 Rose Gold 2
    edited January 29, 2020 4:40PM
    @KathyG - have you checked your source and target database for a schema called RedGateLocal? This is created when using the migrations feature, and is what SQL Compare is checking.

    David Atkinson
    Product Manager
    Redgate Software
  • KathyGKathyG Posts: 18 Bronze 1
    Yes David!  That exists on my target.  Can I just delete it as well?
  • KathyGKathyG Posts: 18 Bronze 1
    Thanks David ... that fixed it.  I have marked the answer.  I appreciate your help.
Sign In or Register to comment.