Error when creating clone

2019-11-19 11:49:41.564 +01:00 [Information] SQL Clone Agent version: 4.0.2.19054, machine name:XXX 
2019-11-19 11:49:41.564 +01:00 [Information] CreateImageRequestEvent (image name:  Operation 106803 started
2019-11-19 11:49:42.845 +01:00 [Information] Directory not found when deleting L:\ assuming it was already deleted
2019-11-19 11:49:43.033 +01:00 [Error] CreateImageRequestEvent (image name: "XXX") Operation 106803 failed with general exception
System.InvalidOperationException: Sequence contains no elements
   at System.Linq.Enumerable.Single[TSource](IEnumerable`1 source)
   at RedGate.SqlClone.Core.StorageApi.WmiStorageSession.GetDisk(DiskImage diskImage)
   at RedGate.SqlClone.Core.VirtualDisk.WmiDiskImageService.<>c__DisplayClass11_0.<CreateDiskImageAndMount>b__0(IWmiStorageSession session)
   at RedGate.SqlClone.Core.VirtualDisk.WmiDiskImageService.RunInsideSession(CancellationToken ct, Action`1 runAction)
   at RedGate.SqlClone.Core.VirtualDisk.WmiDiskImageService.CreateDiskImageAndMount(String diskImagePath, UInt64 requiredSpaceInBytes, UInt64 requestedVirtualSize, String mountPath, CancellationToken ct)
   at RedGate.SqlClone.Core.Vhd.VhdImage.<>c__DisplayClass5_0.<<TakeImage>b__0>d.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at RedGate.SqlClone.Agent.Drivers.Vhd.VhdImageCreationDriver.<CreateImage>d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at RedGate.SqlClone.Agent.Drivers.ImageDriver.<CreateImage>d__5.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at RedGate.SqlClone.Agent.AgentImageService.<CreateImage>d__8.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at RedGate.SqlClone.Agent.AgentImageService.<CreateImage>d__8.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at RedGate.SqlClone.Agent.AgentListener.<Process>d__12.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at RedGate.SqlClone.Agent.OperationContext.OperationLifetimeManager.<Run>d__5.MoveNext()
Tagged:

Answers

  • Hi @osmano ,

    So sorry to hear about this issue you're running into!

    I believe we have a support ticket open with you on this, so I'm just copying my response here:

    The error message you're getting unfortunately doesn't give much detail on the root issue, but we have seen the same stack trace in two previous cases.

    In one of those cases, the problem was that the Microsoft Storage Spaces SMP service was disabled. Can you kindly open your Services panel and make sure that Service is running?

    If not, in the other case, the problem was due to WMI corruption. (At the stage where the error happens, we are using WMI to determine what disks are on the machine.) The other customer seeing the get-disk error followed this article and was able to resolve his problems: https://stackoverflow.com/questions/52324009/how-to-fix-storage-module-cmdlet-when-they-cant-run-on-powershell-windows-10.

    Can you kindly see if either of these resolve the issue in your case?

    I hope that will help but please let me know if not! If the error remains, can you please send across your full log folder, Settings>about 'download log files'?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.