What are the challenges you face when working across database platforms? Take the survey
Options

SQL Change Automation requires .NET Framework 4.7.2 or later

Builds running from TeamCity. Suddenly today database builds failing with "SQL Change Automation requires .NET Framework 4.7.2 or later". No server, TeamCity or to my knowledge SQL Change Automation changes or upgrades. Anyone know what is happening?
Tagged:

Best Answer

  • Options
    AstralTechAstralTech Posts: 2 New member
    Found answer on post about plugin upgrade. Setting builds to select specific version (3.1.18) until we can upgrade the .net framework on the server. Solved.

Answers

  • Options
    Hi Astral,

    We updated the PowerShell today to help with some upcoming work on Sql Change Automation. And as you said you are able to pin to the older version if the new requirements don't work for you.



    Peter
    Peter Gerrard

    Software Engineer
    Redgate Software
Sign In or Register to comment.