SQL Clone Agent "does not have 'change permissions' access for directory path"

OrionUKOrionUK Posts: 26 Bronze 1
When creating an image I am getting the following error message straightaway:

The agent's Windows account <agentservicename> does not have 'change permissions' access for directory path '\\<servername>\SQL Clone\Images' - check Effective Access

I have checked the view effective access and the account definitely has the right permissions (inc full control and change permissions),

Any ideas what other permissions I should be checking?



  • Options
    OrionUKOrionUK Posts: 26 Bronze 1
    I have worked around this by creating a new share on the server hosting the images and adding the SQLCloneAgent account with full control. 

    The original location was using a DFS name so I am wondering if that was causing the issue.

  • Options
    Alex BAlex B Posts: 1,142 Diamond 4

    Hi @OrionUK,

    If the user did not have Full Control in terms of both NTFS file permissions and Share permissions that is generally the cause of the issue.  The permission it mentions is this from one of those:

    This page goes over looking into this and our recommendation of Full Control.

    Kind regards,

    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
Sign In or Register to comment.