Restore permission denied

I do have almost same issue as in https://forum.red-gate.com/discussion/19915/restore-permission-denied
I am using SQL2014 and SQLBackup 8

Backup was created using credentials LIVE\admin and there are 4 .sqb files due to being large DB.
SQL Backup restore fails with the following:

Restoring full backup - Failed
This operation failed with errors.
....
Error 890: RESTORE DATABASE permission denied for database:  (Shop)
SQL error 15404: Could not obtain information about Windows NT group/user 'LIVE\admin', error code 0x54b.
SQL Backup exit code: 890
SQL error code: 15404

The server I am restoring to is a replica of a live system and I've disabled the network connectivity so domain controller can't be contacted.

I have tried few steps in
https://documentation.red-gate.com/sbu7/permissions?_ga=2.240064768.205293046.1545115424-1316247488.1545115424#Permissions-ChangingtheSQLBackupAgentservicecredentials

eg.

Changing the SQL Backup Agent service credentials

and

Using SQL Backup Pro from the command line

sqlbackupc -U sa -P <pass> -I MSSQL -SQL "RESTORE DATABASE [Shop] FROM DISK = 'B:\MSSQL\Backup\FU
LL_MSSQL_Shop_20181021_120000_3.sqb', DISK = 'B:\MSSQL\Backup\FULL_MSSQL_
AU_Shop_20181021_120000_4.sqb', DISK = 'B:\MSSQL\Backup\FULL_MSSQL_Shop_
20181021_120000_1.sqb', DISK = 'B:\MSSQL\Backup\FULL_MSSQL_Shop_20181021_
120000_2.sqb' WITH RECOVERY, REPLACE, ORPHAN_CHECK"
...
Restoring Shop (database) on MSSQL instance from:
  B:\MSSQL\Backup\FULL_MSSQL_Shop_20181021_120000_3.sqb
  B:\MSSQL\Backup\FULL_MSSQL_Shop_20181021_120000_4.sqb
  B:\MSSQL\Backup\FULL_MSSQL_Shop_20181021_120000_1.sqb
  B:\MSSQL\Backup\FULL_MSSQL_Shop_20181021_120000_2.sqb

Error 890: RESTORE DATABASE permission denied for database:  (Shop)
SQL error 15404: Could not obtain information about Windows NT group/user 'LIVE\admin', error code 0x54b.
SQL Backup exit code: 890
Last SQL error code: 15404


I must be missing something - why is it trying to use LIVE\Administrator account for restore it I have specified different credentials with -U and -P ?




Tagged:

Best Answer

  • Dan BDan B Posts: 287 Gold 5
    Accepted Answer
    Hi IgorH,

    Thanks for posting on the Redgate Forums

    So it sounds like one of the permissions checks we do is failing. In the first instance can you try disabling this check by adding following registry key. This won't change the backup behaviour but will give you an error if the permissions aren't sufficient.

    To do this:
    1. Open Registry Editor and locate HKEY_LOCAL_MACHINE\SOFTWARE\Red Gate\SQL Backup\BackupSettingsGlobal\(local) or <instance name>
    2. Create a new DWORD type registry entry called SkipChecks and set the data value to 1.
    3. From the Windows Services panel, stop and restart the SQL Backup Agent service.
    Kind regards,
    Dan Bainbridge
    Product Support Engineer | Redgate Software

Answers

  • igorhigorh Posts: 3 New member
    Hi Dan,
    thanks for your suggestion. First time I ran the restore after, the restore took longer to give error but it said the database is in use.
    I've then killed the processes on that DB and am currently running the restore again. Fingers crossed it has been 3 minutes so it looks promising. Will send another update.
    Thanks

  • igorhigorh Posts: 3 New member
    edited December 20, 2018 2:46AM
    With no changes other than Windows registry above, the restore was completed OK.
    From your explanation Dan I was not expecting that but who am I to complain here ;-)

    Thanks Dan.
Sign In or Register to comment.