Can you help with our Monitor Postgres research? Get involved

Remote Certificate Invalid

I had setup Monitor according to the install directions, and created a local, self-signed certificate in IIS at attached it to the bindings for SqlMontor.  Any time I open SQL Monitor via the client, it gives me an invalid certificate message.  Also in Event Viewer, I have a lot of errors in the Red Gate Software log which are the same:

Description:
2018-11-19 15:56:20,809 [44] ERROR RedGate.SqlMonitor.UI.Website.ReportPoller [(null)] - System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.
   at........

Anyone know how to resolve this?

Tagged:

Answers

  • Eddie DEddie D Posts: 1,686 Rose Gold 5
    Hi Garybr44
    Thank you for your forum post.

    Does the advice in the help article, help you resolve the problem, particularly the section titled "IIS Configuration' and the following section "Add SQL Monitor Web Site"?

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
  • Thanks for your reply Eddie D.  What you recommended does not solve the issue.  I followed it again as I did when I installed.

    Using Firefox, it indicates it doesn't like the certificate because it is self-signed:

    https://tfa-vwebsrv01/
    The certificate is not trusted because it is self-signed.
    HTTP Strict Transport Security: false
    HTTP Public Key Pinning: false
    Certificate chain:
    -----BEGIN CERTIFICATE-----

    Using Edge, it gives me this:

    Your PC doesn’t trust this website’s security certificate.
    The hostname in the website’s security certificate differs from the website you are trying to visit.

    Error Code: DLG_FLAGS_INVALID_CA
    DLG_FLAGS_SEC_CERT_CN_INVALID

    Any browser gives me a similar message.  If I do not use HTTPS protocol, all works fine which is what I will probably do.  Not a high critical connection to keep encrypted.

    Thanks again.




  • I got this error installing version 8. Had to install the web server first by unchecking the monitor checkbox. The webpage that loads up after the web server install has a link to download and install the monitor. Click the link and then click run and the monitor will install!
Sign In or Register to comment.