Reflector 10 not working in VS 2017

TinuTinu Posts: 3 New member

Go To Decompiled Definition (F12) is not working. Pressing F12 shows only '... from metadat', not the decompiled source, Go to Decompiled Definition in contextmenu does nothing... Uninstall/Install Extension/.Net Reflector does not help... .Net Reflector Object Browser in VS is working.

VS 2017 Enterprise, Version 15.7.5

.Net Reflector

.Net Reflector VS Extension VSPro



  • Jessica RJessica R Posts: 1,224 Rose Gold 4
    Hi there,

    Just to confirm, is it failing for every type you try on (even string, int, etc...)? Or is it only failing for certain types?

    If the latter, are there any framework objects that we can test with here?

    Thank you!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

  • TinuTinu Posts: 3 New member


    No type or Method is working. When I press F12, Visual Studio schows the metadata, it seems, that Reflector does not capture F12. Even 'Go To Decompiled Definition' in the context-menu (right-click) does nothing!  Open in .Net Reflector Desktop shows only the metadata from Visual-Studio. Only .Net Reflector Object Browser ist working...

  • Jessica RJessica R Posts: 1,224 Rose Gold 4

    Thanks for those details, @Tinu!

    Just to clarify, the "Go To Decompiled Definition" option will actually only work when you use it from within a file that .NET Reflector generated (it should have a comment at the top //Generated by .NET Reflector from...).

    The "Open in .NET Reflector Desktop" should always work, but it appears there is a bug with this, where it's also only working when you use it from within a file that was generated by .NET Reflector (and opens the metadata file otherwise). Apologies for this! I've logged a bug with reference RP-3979.

    The "Go to definition (F12)" option should be working for everything though (I did a quick test with NewGuid() as well to make sure that was working for me, and it was able to decompile). In case your install is corrupted, can you kindly try uninstalling and then reinstalling the latest .NET Reflector extension from here: 

    If the problem remains though, can we please check what other VS extensions you have installed (if any)?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

  • rjperesrjperes Posts: 1 New member
    In my case, both Open in .NET Reflector Desktop and Go to Decompiled Definition appear disabled, so I can't use them.
  • davidjadedavidjade Posts: 2 New member
    I have this same problem in VS 2017 Enterprise. The menu options don't work. Open in Reflector Desktop just opens from metadata in VS. Go to Decompiled does nothing. Pressing F12 is the only thing that works. I removed/re-installed the extension and it's still not working. Can't believe this is still broken after months from being reported.
  • Hi all,

    Thanks for your posts and sorry this "open in .NET Reflector Desktop" issue isn't fixed yet! I'm following up on this with our developers.

    Regarding "Go to Decompiled definition" @davidjade, this will only work from within a file that was created by .NET Reflector. F12 will work either way (but you do need to make sure you have the GoToDefinition (F12) override enabled from the .NET Reflector menu).

    Is "Go to Decompiled definition" failing on a Reflector-generated file? Can you let us know what type it's failing on so we can try to reproduce this?

    @rjperes, it sounds like you may be running into a different issue. Could you please share a screenshot of what you were seeing?


    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

  • davidjadedavidjade Posts: 2 New member
    @Jessica R F12 is working for me - it shows the decompiled definition. Within that decompiled file, "Go to Decompiled definition" seems to work as well but so does just pressing F12 again within the decompiled file.

    A bit of feedback: I guess I find this "Go to Decompiled definition" menu option a bit confusing, especially given that it is enabled all the time and does nothing most of the time (i.e. can only be used in decompiled files). It effectively just seems to duplicate the functionality of F12/"Go to Definition" as that can also be used in decompiled files.

    So what is it's purpose? How does it differ from just using F12? Is there something I am missing here? If it is meant to make things more discoverable then I think it failed as I expected it to always work to show a decompiled definition (as its name implies).
  • TinuTinu Posts: 3 New member

    F12 is still not working for me (Pressing_F12.png, Result_Pressing_F12.png). I Add also screenshots of my installed extensions.

    Microsoft Visual Studio Enterprise 2017, Version 15.8.9

    .NET Reflector, Version Pro (Extension = same Version)

  • Jessica RJessica R Posts: 1,224 Rose Gold 4
    Hi @davidjade, thanks for confirming that and apologies as I know the two options can be confusing! From what I recall, the "Go to decompiled definition" option is there just in case the standard "Go to Definition" fails on Reflector-generated code (though it normally doesn't). I have passed on some feedback to our developers though letting them know that the wording is quite confusing and we can hopefully change this!

    @Tinu, can I first just confirm that the menu option .NET Reflector>GoToDefinition (F12) is enabled?

     If it is, can I also just check if F12 is opening the metadata for every type you try on, in any solution? (Even in a new solution, trying on "string"?)

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

Sign In or Register to comment.