On-demand training: More Gems from the SQL Prompt Treasure Chest. Watch now.

Can't Uninstall SQL Prompt 8

ZackSZackS Posts: 3 New member
I'm using SSMS v17.1 and I just tried to uninstall SQL Prompt 8 but the uninstaller just hangs. I was able to successfully uninstall SQL search and framework install entry, but not in the SQL Prompt 8. I ended up just deleting the entire RedGate folder in program files and it did the job, however this looks to be some type of bug.


  • bmlbml Posts: 4 Bronze 1
    I have exactly the same issue. No luck removing the folder. SQL Prompt v.
  • So sorry to hear you've both ran into this issue!

    I believe we had a support ticket open with @ZackS and sent the following suggestion:

    - Open your registry with regedit and go to the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall key
    - From there, please search through under that key for "SQL Prompt 8" and locate the subkey that contains the DisplayName value "SQL Prompt 8" and take note of the UninstallString value (similar to below)


    - Please then open a command prompt running as administrator and then try running the UninstallString value which will hopefully successfully uninstall it (or give a better error message if not)

    @bml, can you please give this a try? @ZackS, if you are still running into issues as well and this hasn't helped, please let us know!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

  • bmlbml Posts: 4 Bronze 1
    @Jessica R Thank you so much! This did the trick and I was able to uninstall. I then reinstalled and now I see the SQL Prompt menu in SSMS 17.2
  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    So glad to hear that helped @bml!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

  • @Jessica R - Any idea what to do if the command prompt uninstall doesn't work? I tried to uninstall from Programs and Features. It acted like it uninstalled the products, but then they were still there. I tried the command prompt process above; still there. At this point, short of deleting everything manually (which i really don't want to do), i'm not sure how else to go about this. The ones in particular giving me issues are: SQL Compare 13, SQL Data Compare 13, SQL Data Generator 4, SQL Dependency Tracker 3, SQL Doc 4 (this shows up twice in my list and I can't uninstall either), SQL Search 3 (also shows up twice) and SQL Test 2. I have Microsoft Windows 10 Pro
    OS Version: 10.0.16299 N/A Build 16299.
    Any help you can provide would be great. thank you!
  • Hi @rshakespeare

    This looks like a question that one of Support engineers will need to investigate for you.

    If you've a got support contract, please send us a ticket. Provide as much information as you can - screenshots of any errors, log files etc – so we can help you as fast as possible.
    If you're not covered by a Support contract at the moment, email our Sales team at [email protected], and they'll be able to help.
    Customer Support
    Redgate Software
  • percywilliamsonpercywilliamson Posts: 1 New member
    edited December 18, 2018 10:11AM
    came here searching for an answer to precisely this and the second post from jessica did the trick for me. Thanks 

    know bits of sql and also few other things.
  • So glad that helped, @percywilliamson!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

Sign In or Register to comment.