Ignore system named constraint and index names Not working

mikecaremikecare Posts: 16 Bronze 4

km30p8uxt2kq.png

I have set the options to ignore, then save and then refresh and still get different named constraints
psmcuq84vnlm.png

Comments

  • wdhenrikwdhenrik Posts: 15 Bronze 1
    Can you verify if Ignore System Named Constraint and Index Names is also selected? That option is further down the list. The options you have in your screenshot may only be ignoring user named constraint and indexes.
  • Thanks for your post,

    Are there other differences in the two table definitions? Does this table show as "in both , but different" in the upper comparison grid?

    The logic to determine if objects are shown as different or identical in the upper grid is aware of the options you have selected. If you were to select this object to be deployed you should see no change being deployed to the constraint name. If you are seeing changes in the deployment script, we have a bug that we should investigate in more detail.

    The lower pane of SQL Compare will show a textual difference between the two objects as they would be returned from SQL Server. This view is not aware of the option you have provided as it performs a naive text comparison. This does seem like one of the cases where we could avoid scripting out the constraint names to avoid this confusion. I'll have a look and see if there are any improvements we can make.
    Software Engineer
    Redgate Software
  • mikecaremikecare Posts: 16 Bronze 4
    Yes, they are "in both but different" No other differences that I can see exist. What seems to work for me is that I had to also choose the "Ignore System Named Constraint and Index Names" option. I only saw this as a command line option in searching and did not realize it was an UI option as well. This seems to have "fixed" the options for me and gives me what I need. Thanks for the assistance!
  • kevrileykevriley Preston, UKPosts: 129 Gold 1
    I think this could be made more explicit in the UI.

    I just had the same issue, in that I checked 'Ignore constraint and index names' but was still seeing differences which turned out to be system-named constraints. Until I found this thread.

    So 'Ignore constraint and index names' should include system-ones by default, maybe even move the 'Ignore System Named Constraint and Index Names' underneath (tabbed in, even) so that it's obviously clear that there are options here.
Sign In or Register to comment.