Invalid version for Type RedGate.Vcs.Common.SerializeFormatterInitializer+VaultStd6Location

We were using Vault with SQL Source Control 5, and two of our databases would show this error when any of us go to the Commit tab: "Invalid version for Type RedGate.Vcs.Common.SerializeFormatterInitializer+VaultStd6Location"

Other databases worked fine. We just switched from Vault to Git, unlinked the databases from Vault and linked to Git, and the same databases are still showing the same Vault error on the Commit tab. I tried renaming my %localappdata%\Red Gate\SQL Source Control 5 to .old, but after restarting SSMS I still get that error.

Since it persisted me removing my settings and across different developers' accounts and computers, I'm not sure where this information is stored. Do you have any information that might help us resolve this?


  • DougSNDougSN Posts: 2 New member
    I figured out a workaround.

    in SSMS, right-click the database in Object Explorer > Properties > Extended Properties > SQLSourceControl Scripts Location > Change “VaultStandardVersion6Location” to “VaultStandardVersion8Location”

    We probably need to figure out what we need to change it to for our new Git system, but at least we can see and commit changes now.
  • Jessica RJessica R Posts: 1,213 Rose Gold 4
    Thanks for your post! Ah yes, this error may come up when you have any extended properties on the database that relate to SQL Source Control. They aren't necessary anymore with SQL Source Control 5, so renaming should resolve the error.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

Sign In or Register to comment.