Recording hangs indefinately

Ian1971Ian1971 Posts: 44
edited October 4, 2004 2:04PM in ANTS Load
We have just purchased ANTS load professional and I am trying to use it to record a web site script. I am having some trouble doing this. I can navigate to my web site (on my local machine) and I can access one or two pages, but then I start getting no response from my web site, it looks like it is doing something but it never returns.
If a run my website normally it works with no problems.
Do you have any ideas what the problem might be?



  • It doesn't seem to be a specific page that is causing the trouble. Unfortunately it is an intranet application so isn't possible to show you.
    Could it be something to do with the proxy?
    I might try re-installing ants to see if that helps. It was working fine a while ago, when I was evaluating the software and has only had problems since I put in our license key (doh).
    I have installed various other bits of software since so maybe something has screwed it up
  • Ok. I re-installed, and it seemed to be working ok, but it isn't.
    The problem seems to be when I am logging in to the website. Could it be something to do with the authentication ticket that uses?
  • I realised that one of the changes that we had made since I originally tried out ANTS load was to use Server.Transfer in place of Response.Redirect whereever possible (to get around a MAC IE bug...long story). I tried setting the app back to using Response.Redirect instead and it no longer seems to hang randomly whilst recording.
    Sounds like a bug?[/b]
  • Ian,

    It does indeed sound like a bug - thank you for spotting it. It sounds like you have a workaround though - are you comfortable with that?

    - Neil
    - Neil Davidson
    Red Gate Software Ltd
  • I am fine with the workaround, as I can easily build some compile switches into the app so I can build a "loadtest" version of the app that doesn't use Server.Transfer between pages.
    Would be good to get this sorted in a future build tho'

This discussion has been closed.