SQL Doc upgrade crashed SSMS

a.higginsa.higgins Posts: 90 Bronze 2
edited March 15, 2017 1:06PM in SQL Doc
This morning, SQL Doc prompted me to install the latest version. I did so, and was immediately unable to open SSMS - every time it would come up, throw an "SSMS has stopped working" error, attempt to restart itself, throw another "SSMS has stopped working" error, and then die.

I rebooted my machine and performed a Repair Install of SSMS without any change. Then, I uninstalled SQL Doc and was instantly back in.

I'm running Windows 7 on an x64 machine (Operating System 6.1.7601), using Microsoft SQL Server Management Studio version 13.0.16106.4

For now, I'm going to run without SQL Doc ... let me know if there's any other information I can provide that would help you.
Tagged:

Comments

  • Alex BAlex B Posts: 1,131 Diamond 4
    Hi a.higgins,

    My apologies for the issue you are experiencing with SQL Doc crashing your SSMS!

    It seems there's an issue where SSMS 2016 is crashing when either SQL Prompt or the latest of all three of (SQL Doc, SQL Data Generator and SQL Dependency Tracker) are installed at the same time. Removing either Prompt or the three other programs will stop SSMS from crashing. If you don't use either Prompt or the other three tools you can remove one or the other or you can use this installer to install the previous versions of the three tools which work properly together with the latest version of SQL Prompt.

    The developers are working to get the issue sorted out and should have a new installer out in the near future.

    Please let me know if this works for you or if you run into any further issues!

    Kind regards,
    Alex
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
  • Alex BAlex B Posts: 1,131 Diamond 4

    Hi a.higgins,

    We've now released a version of the SQL Toolbelt with the latest versions of the products that all work together in SSMS 2016. Please download it here and let me know if you run into any further issues!

    Kind regards,
    Alex

    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
  • MiriamkaMiriamka Posts: 6 Bronze 1

    Finding this post gave me the direction where to look for the solution, almost 7 years later and more advanced versions of red-gate products and MS SQL Server. 

    I got the same issue when applying latest update for SQL Doc 5 (from SQL Doc 5.2 to SQL Doc 5.2.16). It resulted in the crash of SSMS 17 and SSMS 18, with an error message in the log:

    "Failed to resolve source for file: C:\Program Files\BMC Software\Client Management\Client\data\PatchManagementPremium\Patches\Jobs\1389\Base\Patches\SSMS-Setup-ENU-Upgrade.exe, error: 0x80070002.
    Error 0x80070002: Failed while prompting for source (original path 'C:\Program Files\BMC Software\Client Management\Client\data\PatchManagementPremium\Patches\Jobs\1389\Base\Patches\SSMS-Setup-ENU-Upgrade.exe').
    Error 0x80070002: Failed while caching, aborting execution."

     The situation was that after applying the latest SQL Doc 5 update (version 5.2.16) - the SSMS will come up, but crashed right away when I will try to open Text Editor or try to open Query Explorer.

    Also, in the end of that update of SQL Doc 5 to latest update (version 5.2.16) the message popped up, requesting to restart the computer, the situation which NEVER happened to me before with any of red-gate products latest updates. 

    I had to un-install all of red-gate products from our SQL Toolbelt Essential subscription 2022, reinstall SQL Server Management Studio 2017, and re-install again red-gate products back one-by-one, testing every time that SSMS is still working.

    I updated all of red-gate products to the latest updates, making sure that SQL Doc 5 update was the last. I know that the crash-culprit was the latest update for SQL Doc 5, because the crash of SSMS happened again right away. I discarded the latest update for SQL Doc 5, keeping my working version 5.2.

     

    I am running on:

    Windows 10 Enterprise, 64-bit operating system, x64-based processor

    SQL Server Management Studio 2017 (version 17.8.1)

     I think it might be something really wrong with the SQL Doc 5 latest update, and red-gate development team should be notified about it.


  • Hi @Miriamka

    Are you able to confirm the version of SQL Doc that you upgraded from? Was it 5.2.0 or a later version? 

    Also if you uninstall the latest version of SQL Doc and then reinstall do you still get the same issue? 
  • MiriamkaMiriamka Posts: 6 Bronze 1
    edited February 1, 2024 4:08PM
    Hello @Ben_P,
    My original version is SQL Doc 5.2.3.2913.
    After getting the issues and uninstalling SQL Doc (v 5.2.16) from my computer, I didn't download the fresh latest SQL Doc 5.2.16 from redgate website; I was just cautious. I simply installed back my original version of SQL Doc 5.2.3.2913, which I know worked well. 

    Thanks for taking care of the product,
     Miriamka
  • In my testing, I was only able to get the crashing issue to happen once, after uninstalling 5.2.16 and then reinstalling the crashing no longer happened. If you get a change, are you able to try the upgrade once more? 
  • When you initially updated to the latest, did you have both SSMS and SQL Doc open? 
    If not, could you perhaps try this when updating? 
  • MiriamkaMiriamka Posts: 6 Bronze 1

    Hello @Ben_P ,

    To answer your question: I always have SSMS open all the time as it is required for my work. 

    And anyway, all “latest updates/upgrades” of red-gate usually requesting to close all SSMS and VS running of the time of the update.

    For me the crash of SSMS happened twice this week. Both times it was installing latest update of SQL Doc 5 (v 5.2.16). No other latest updates from our SQL Toolbelt crashed my SSMS.

    Now, today based on your recommendation I checked for Latest Update for my SQL Doc 5.2.3.2913. Downloaded it. Started installation. It asked me to close all open SSMS. I closed all of them. It installed SQL Doc 5.2.16 update to my computer. In the end it said that “Required restart to complete installation”. In the past I already twice ran into a problem with this restart, required me to re-install SSMS and reinstall my original SQL Doc 5.2.3.

    WHY it required me to restart?  For last 20 years of using multiple red-gate products it NEVER asked me to restart.

    I didn’t risk anymore. I uninstalled SQL Doc 5.

     Do you have any other suggestions of how to get SQL Doc with latest updates?


  • creynoldscreynolds Posts: 2 New member
    I have also just encountered this issue.  It is occurring on a new laptop being set up for me and I just broke my SSMS on my current laptop by upgrading SQL Doc 5.  :(
  • Hi,

    Please uninstall SQL Doc and then reinstall the latest version here:

    https://download.red-gate.com/checkforupdates/SQLDoc/SQLDoc_5.2.16.4047.exe

    The issue seems to occur when upgrading from an older version. Other users who have uninstalled the tool and performed a clean installation after have not seen a reoccurrence of the issue.

  • creynoldscreynolds Posts: 2 New member
    As I mentioned earlier, a new laptop with all new installs had the same issue.  Uninstalling doc 5.2.156 resolved it and reinstalling it alone again rebroke SSMS.  Reinstalling the older version was the only solution that has worked.
  • I'm seeing the exact same behavior. SSMS seems to be failing when the SQL Prompt cache is being refreshed.
  • Thanks, @Ben_P, that resolved the issue.
  •  Hello @Ben_P ,

    Unfortunately, your latest suggestion didn’t work in our case.

    I un-installed old SQL Doc v5.2.3.2913, downloaded latest version of SQL Doc v5.2.17.4123 from link you provided above. After installation of latest SQL Doc I was able to open it, connect to one database and create document. All good here, but when trying to open SSMS 2017 (v17.8.1) or SSMS 2018 (v18.12.1) both SSMS crushed, and it didn’t work even after restart of the computer.

    One of the error messages was from SQL Prompt (“Pipe is broken”), even I didn’t do any changes related to SQL Prompt. Our SQL Prompt version is v10.14.6.5992. (I submitted an error report to red-gate)

    After un-installing SQL Doc from my computer I was able to open both SSMS (v17 and v18).

     Do you have another suggestion how to get latest version of SQL Doc?

  • Hi @Miriamka

    Are you using a connection to SQL Server Analysis Services or Reporting Services when this issue happens? Other users have noted that when connecting to such services with SQL Doc installed, it causes similar behaviour. 
  • MiriamkaMiriamka Posts: 6 Bronze 1
    Hello @Ben_P,
    To answer your question: No, I don't have SQL Server Analysis Services or Reporting Services installed on my computer. I don't have any connection to these services.
    I tried one more time to install SQL Doc v5.2.17.4123, following the same steps, and WITHOUT any success. I just simply got the same problems.
  • Unfortunately, the devs still can't replicate the error.
     
    By the way, a version supporting SSMS 20 will be released soon. 
    Many updates have been introduced there that affect the operation of the program, which may help solve the problem. A few more tests for the installation need to be performed for the latest SQL Doc and if everything goes well it should be out later today or tomorrow. 


  • MiriamkaMiriamka Posts: 6 Bronze 1
    edited March 27, 2024 1:46PM
    Thanks @Ben_P. However, I am specifically using SSMS 17.8.1 for the reason that it has Debugger, which was removed from the latest SSMS versions. I am planning to use SSMS 17 as long as I can because of that.
    Looks like I have to abandon the ideas for latest updates for SQL Doc, and stick to the older, working version.
    And, by the way, recent update for SQL Search v 3.6.14.4342 made my SSMS 17 crashed as well. I had to un-install it and re-install my working version 3.6.2.3390. That was serious crash when all my personalization settings, list of all Server names in Connect to Server has just gone. 

Sign In or Register to comment.