What are the challenges you face when working across database platforms? Take the survey
Options

Installation failed - Overlapped I/O operation... 1603

bradbuchananbradbuchanan Posts: 5
edited June 16, 2016 4:15AM in SQL Compare 11
I'm attempting to install SQL Compare 11.6. I'm currently a SQL Compare 9 user and I'm looking to evaluate 11 for upgrade.

The installer that was downloaded is SQLDeveloperBundle.exe and I have selected to only install SQL Compare 11.6 and SQL Search 2.3. I've attempted running the installer as admin to assure that permissions were not the issue.

The install of SQL Compare 11.6 fails soon after unpacking with an "Overlapped I/O operation is in progress. (MSI Error: 1603)" error.

Is that enough detail for you to point me toward or a solution?

If you need more details please provide me with instructions on how to generate a detailed install log I'll do that and post the results here.

Comments

  • Options
    Hi Brad,

    Searching the net for other people who've experienced this issue, it seems to be related to the Microsoft security update KB2918614. There is a hotfix available for this issue that you can download here - https://support.microsoft.com/en-us/kb/3000988

    Could you install the hotfix and try installing again? Let me know if it helps.
    Software Engineer
    Redgate Software
  • Options
    Thanks Robert,

    Gave that HotFix a try and the installer reported that is was already installed on my system.

    Just in case, I attempted to run the installer again as admin and got the same error as before.

    Is there anyway I can get you more feedback from the installation process that would help?
  • Options
    Hi Brad,

    Sorry to hear that didn't work for you. Try running the installer with the following command line in order to save a logfile.
    SQLDeveloperBundle.exe log c:log.txt
    
    Once you have a logfile, post the contents here and I'll take a look at it.
    Software Engineer
    Redgate Software
  • Options
    The log file is quite long and is over the limit of the forum so I've tried to pinpoint the issue

    There is the regular unpacking process then quite a few "Failed to find process info for" followed by the Win32Exception much like the one included here just for different processes.
    [2016-06-15 12:53:59] Failed to find process info for System.Diagnostics.Process (svchost)!
    [2016-06-15 12:53:59] System.ComponentModel.Win32Exception (0x80004005): A 32 bit processes cannot access modules of a 64 bit process.
       at System.Diagnostics.NtProcessManager.GetModuleInfos(Int32 processId, Boolean firstModuleOnly)
       at System.Diagnostics.NtProcessManager.GetFirstModuleInfo(Int32 processId)
       at System.Diagnostics.Process.get_MainModule()
       at RedGate.InstallerWizard.Engine.ProductSet.FindProgramsRunning(IList`1& running)
    [2016-06-15 12:54:00] Logging started for thread 12 ''
    [2016-06-15 12:54:00] Moving C:UsersBradBuchananAppDataLocalTemp{F98E17D8-C0E6-43DD-8039-1C5E9CD1B608}SQL Compare to C:ProgramDataDownloaded Installations1FFCB436C8A967176A618C92C40992B2
    [2016-06-15 12:54:02] INSTALL - 'C:ProgramDataDownloaded Installations1FFCB436C8A967176A618C92C40992B2SQL Compare_11.6.3.1926_x86.msi' params RG_I="SQL Developer Bundle"  RG_WARNING="Ignore" INSTALLDIR="C:Program Files (x86)Red GateSQL Compare 11" REBOOT=ReallySuppress REINSTALLMODE=amus
    [2016-06-15 12:54:03] MSI:  Error- Overlapped I/O operation is in progress.
    
    [2016-06-15 12:54:03] RedGate.InstallerWizard.Engine.SQLToolbeltInstallerException: Overlapped I/O operation is in progress.
     (MSI Error: 1603)
       at RedGate.InstallerWizard.Engine.TaskItem.MSIItem.Run()
       at RedGate.InstallerWizard.Engine.Product.#LBnb.Run()
    RunProgram returned 0
    Remove folder 'Yes'
    
    This is then followed by the file and registry cleanups.
  • Options
    Hi Brad,

    Here are some individual installers for SQL Compare 11.6.6 and SQL Search 2.3 - give these a try and see if they work.

    If not, then try installing from the MSI file. You'll need to extract it from the executable and we have some instructions on how to do this here - https://documentation.red-gate.com/disp ... +.msi+file
    Software Engineer
    Redgate Software
  • Options
    SUCCESS!!!

    I've now installed the updated version of SQL Search via the download you provided.

    SQL Compare is also installed but it was a bit more of a challenge and I wanted to document for others that may have a similar issue.
    1) Extracted the .msi from the SQLDeveloperBundle.exe I had downloaded using the instructions you provided, on initial run this failed again but I didn't give up
    2) I ran the msi installer from the command with the switches to produce a log file
    msiexec /i "SQL Compare_11.6.3.1926_x86.msi" /l*v c:_stufflogssqlcompare.log
    
    3) Reviewed the log file and found a "SECUREREPAIR: Failed to CreateContentHash of the file: Red GateSQL Compare 11RedGate.SQLCompare.UI.exe.config: for computing its hash. Error: 997" error. From that found http://stackoverflow.com/questions/28019083/net-4-fails-to-install-because-securerepair-fails-to-createcontenthash-of-file which lead me to https://support.microsoft.com/en-us/kb/2918614. I made the registry changes in the KB and ran the installer successfully.
  • Options
    Hi Brad,

    That's great to hear! Thanks for letting me know.
    Software Engineer
    Redgate Software
Sign In or Register to comment.