Error: All keys contained ... but neither existingResults...

Jeff ClarkJeff Clark Posts: 14
When I go to the Commit Changes tab for a particular database, I get this error (and other users get it as well):
All keys contained 1597506878 but neither existingResults or newResults contained that key.

The afflicted database was working previously and there were no significant changes (that I know of) to the database, configuration, software versions, etc. Other databases on same server continue to work fine.

SQL SC Std. (latest version)
SQL Server 2014 Enterprise Edition
Shared mode for database
SQL Server Management Studio 12.0.4100.1
Windows 7

I have also run "Send error report" this morning. I cannot copy the text out of the error details in the Commit Changes tab.

Can you tell me how to recover from this error and prevent it in the future?

We will probably end up restoring the database and see if that works. However, that means lost developer time. I'd welcome a better solution.

Thanks in advance,

PS After posting, I found an update to SQL Source Control if I turned on Frequent Updates. I'm now on I still get the same issue.
I also notice that the database with the problem shows the "Checking for Modifications" icon continuously. It's been about 30 minutes now. All the other databases show that just briefly.


  • Hey Jeff,

    Thanks for your post and sorry you are having these issues!
    I have followed up with you via email for further troubleshooting.

    Thanks for your help!

    All the Best,
    Andrew Pierce
    Technical Sales Engineer
    Redgate Software
  • Andrew suggested I try clearing the local data cache:
    Try clearing the contents of each folder in %localappdata%Red GateSQL Source Control 4Caches- move them to an alternate folder first so that Source Control rebuilds them and see if you still have this issue.

    That worked. Great. Thanks. Issue resolved.
  • This issue re-occurred for us this morning. We had restored our (shared) source controlled databases from production.

    We had to clear our local data caches again to fix the error.

    Could you handle this fix automatically in the future?

  • @AndrewPierce -

    Rather than just following up by private email, why not post the solution on the board for everyone else?

    @Jeff Clark -

    Thanks for posting Andrew's solution. It also worked for me, and I wanted to second your suggestion - if SQL SRC Control recognizes its cache is corrupt, why not just have it wipe it itself?!? Posting an error and making the user do it is a poor user experience. I spent all morning on this before finding your solution Jeff.

Sign In or Register to comment.