LINK DB to source Control

pcapircipcapirci Posts: 6
I use SQL Source Control since its birth! Recently I have updated SSMS to SQL Server 2014 version and also SQL Source Control to 4.1.15. But now I can't link anymore a DB to source control. I select a DB, but SQL Source Control says "No database selected". I use also "right click" approach, but I receive the same answer. The DB is on a server, not on my computer.
UPDATE after some tests: I connected to the local instance of SQL Server. Then I attached a local new DB to Source Control (just the first step, without complete the whole process). Then I have tried again to attach the remote DB to Source Control, and now it worked. Please note that I have done several attempts on the remote SQL Server before trying this workaround, without any success. I have also disconnect to the remote server, close SSMS, open again it and reconnect to the remote server, without any success.
PLEASE NOTE that I have repeated more times the procedure (first to link from remote server, then from local server), and its behaviour was perfectly the same all the times. I suppose this is a bug ....


  • Hello,

    Sorry for the issue you are having with SQL Source Control. We've opened a ticket to troubleshoot this issue further, thanks.
    Allen LeVan
    Red Gate Software
    US Product Support
  • I am having the exactly the same problem.

    I'm Running SQL 2014 SP1 Cume 5 - Build 12.0.4439.1
    Source Control Version Standard

    Mickeal Davis
    Mickeal Davis
    Enterprise Architect
    City of Swan
    Western Australia
Sign In or Register to comment.