Cannot retrieve CLR version

ramon22ramon22 Posts: 3
edited March 21, 2015 6:55AM in SmartAssembly
I build a WPF App for release that uses Sqlce, and tried to open it with SmartAssembly it fails with this error Cannot retrieve CLR version, what am i missing thanks
Tagged:

Comments

  • Jessica RJessica R Posts: 1,009 Rose Gold 3
    Hi there,

    Thanks for your post!

    Can I please check--what version of SmartAssembly are you on? If you're not on the latest (6.9) can you kindly try updating from Tools>Check for Updates?

    I believe this error would happen when a dependency did not reference mscorlib (System.Diagnostics.Tools.dll of .NET 4.5 for example) but it was resolved in version 6.8.

    I hope updating helps! Please let me know how you get on or if you're already on the latest.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Hi
    Am using version 6.5.2.2.1, i will try to update to latest version and see if it resolves the bug.
    thank you
  • TKTTKT Posts: 1 New member
    I am using SmartAssembly version 6.13.3.1314 and getting this same error message when trying to create a project that requires a reference to Windows.winmd.  It doesn't give me the option to exclude it.
  • SmartAssembly doesn't support applications that reference winmd assemblies, I'm afraid.
    Have you visited our Help Centre?
Sign In or Register to comment.