Result window not scrolled to correct position

KevinGreinerKevinGreiner Posts: 42
edited December 5, 2014 4:21AM in SQL Search
I just installed SQL Search v2, upgrading from v1. It looks quite different but nice, especially the selection of multiple databases.

When scrolling through search results, I noticed the bottom results window was moved to a position in the middle of the script. But no yellow highlighted text was displayed. I have to scroll the results window up 5-10 lines to see the highlighted text.

This is consistent across multiple searches and multiple search results.

Using Windows 8.1 and multiple monitors.


  • jimVisage1980jimVisage1980 Posts: 11 Bronze 1
    I'm getting the same problem SSMS 2008 R2 and Windows 7

    Shame really as all the other changes are most welcome but not jumping to the search term is a real pain.

    Please fix Redgate and many thanks for this most useful of free tools.
  • jcatjcat Posts: 9
    edited May 15, 2014 11:48AM
    Yep, same problem here. I didn't notice at first because a couple of my searches returned very short code that fit in the results window, but with longer code results it never scrolls to the correct (matching code text) position.

    I'm sure it'll get fixed soon, but for now it's really frustrating. I love the fact that they finally fixed it so we can copy from the results window - that's huge. For that plus searching through Jobs as well I'll stick with this version and hope for a fix to the scroll problem in the near future.

    EDIT: wanted to add my environment in case it's helpful for the devs.

    SSMS 2012
    Windows 8 x64
  • Hey everyone I am getting the same problem, too. Maybe they would notice this and fix it up in the next minor update.
    C, C++, Java, HTML & css, php everything is fun.
  • kevrileykevriley Preston, UKPosts: 129 Gold 1
    Just to add I'm experiencing the same issue.

    SSMS 2008R2

    SSMS 2012
  • Hi everyone,

    Thanks for the feedback. We're really interested in this bug, as we spent a long time trying to get the highlighting and scrolling right, and it sounds like we haven't quite solved it after all.

    It would be really useful if you could give examples of specific searches that aren't being highlighted, along with the relevant parts of the schema you're searching against. If you'd prefer not to send them in a public forum, feel free to DM me, and I'll pass your examples to the team.

    Dominic Smith,
    Project Manager,
  • jimVisage1980jimVisage1980 Posts: 11 Bronze 1
    Hi there Dom,

    In my case the problem happens for all searches and I specifically see the problem for match of text in db object type stored procedure or function.

  • kevrileykevriley Preston, UKPosts: 129 Gold 1
    I've noticed it on fairly long stored procedures. Let me see if I can get an example.
  • jimVisage1980jimVisage1980 Posts: 11 Bronze 1
    I've got a 44 line stored proc and the jump to found text works ok.
    A stored proc of more lines and the jump to doesn't work.

    I don't know the exact cut-off but an SP of 96 lines definitely causes issues
  • kevrileykevriley Preston, UKPosts: 129 Gold 1
    Here's an example using AdventureWorks2008 or AdventureWorks2008R2 or AdventureWorks2012.

    Search for the text 'proc'. Click on the result 'uspGetBillOfMaterials'

    Display pane scrolls down the proc, away from the highlighted obvious 'proc' in the first line.
  • Thanks, we'll look into that.
    Dominic Smith,
    Project Manager,
  • jimVisage1980jimVisage1980 Posts: 11 Bronze 1
    Hi guys,
    Any movement in fixing this problem?

    Must admit that for me all the new features in version 2 have been negated by the inability to jump to the highlighted line in the results screen.

    I'll probably revert to version 1 in the meantime.

    Cheers for a great FREE tool. Efforts are appreciated.
  • gregsohlgregsohl Posts: 2 Bronze 1
    Thanks for the updated tool!

    I'm seeing the same issue with the preview windows scroll position. As an example, I searched stored procedures for "Create Procedure", in a particular database. I got > 400 results. I looked 100 of the results. As I select each result in the results window, the preview window shows the procedure body starting 3-10 lines below the "Create Procedure" highlighted text. The only ones that show the correct text are ones that are shorter than one preview window tall.

  • Hi Dominic

    It's been 6 months now. Any chance this problem will be fixed?

  • Just to update you all on this issue: I've taken a look at this issue and believe I have a fix for it. We still need to do a bit more testing, but hopefully we should be able to push the fix live sooner rather than later.

    Regards; Chris
    Software Engineer
    Red Gate Software
  • That's good news Chris.

    Nice little Christmas present.

  • This fix should now be live in build - SQL Search should auto-update itself so you shouldn't need to do anything* to get the new version.

    *actually - it only checks for updates the first time the tab is opened, and then only installs updates the next time SQL Server Management Studio is restarted, so you may need to restart SSMS, open SQL Search, then close and re-start SSMS to get the update - a bit annoying, I know
    Software Engineer
    Red Gate Software
  • This is excellent Chris.
    I have tried it out and the results screen now shows the first match in a SPs etc.

    For those of us struggling with somebody else's code this tool is a real boon and now that the problem is fixed I am a happy camper.

  • LindaLinda Posts: 1 New member
    Hi, I have the same problem using SQL Search on SQL Server Mgmt Studio 17.6. Automatic focus on the search term used to work for me but I can't remember what configurations of the products it worked on. The problem occurs constantly, even on an object with as few as 50 lines. It's frustrating and time-consuming to scroll through every returned object. Please let me know if/when there is a fix. TIA.
  • DellyDelly United KingdonPosts: 8 New member
    I'm too using version and have noticed the automatic code focus isn't working when i scroll through the search results. Very frustrating on stored procedures over 1000 lines long.   Just glad i'm not the only one. If Redgate could confirm this is being investigated that would be awesome. 
  • af99af99 Posts: 1 New member
    Hi, I have the same problem using SQL Search on SQL Server Mgmt Studio 13.0
  • The problem still exists in version / SSMS 17.9.

    After scrolling down the first result, the second result tries to open at the exact same scroll-position as first result.
    If result 1 is a very long procedure and I scroll to the bottom and change to result 2, it now tries to position the result-pane below EOF, resulting in at empty result (until I scroll up)
    // Henrik
  • You are correct. A fix for this should be out with the next release
  • You are correct. A fix for this should be out with the next release
    Just installed V3.2.1.2206 and the positioning of the results works WAY better now.
    Thank you!
    // Henrik
Sign In or Register to comment.