SQL Monitor 4.1 monitors host / no longer monitors DB

tstriebertstrieber Posts: 3
edited October 10, 2014 3:05PM in SQL Monitor Previous Versions
SQL Monitor 4.1 monitors the host machine but now fails to monitor the database:

SQL Monitor is no longer monitoring 3 of my 7 databases, instead it only monitors the host machine. I've tried 'retrying the connection' and suspending/enabling the monitoring but nothing has worked.


If I navigate to: "Configuration > Monitored servers >\(local)", it tells me that it is connected and there are no errors in the log.

These databases have been monitored fine for at least 6 months. Only after updating to 4.1 have I ran into this problem.


  • Hello,

    Thanks for your post and sorry you're experiencing issues with SQL Monitor.

    One hypothesis I have is that the account the "SQL Monitor 4 Base Monitor" service is using has changed. (There shouldn't be anything different about the data collection methods between the two versions.)

    You can also check on the monitored servers page (in configuration) to see what the failures are. If you hover over the entity that isn't connected, there should be a "show log" link on the right. That should tell you which data collection methods are failing and what the error messages are.

    If you'd like to troubleshoot further, we have a ticket open for you (#23640), so feel free to respond to the email you should've gotten from our support system or email [email protected].

    Evan Moss
    Product Support
    (866) 627-8107
  • Evan MossEvan Moss Posts: 112
    edited July 28, 2014 10:29AM
    For anyone else looking at this post, restarting the Base Monitor service seems to have solved it. It looked like it was related to a WMI outofmemory error.
    Evan Moss
    Product Support
    (866) 627-8107
  • Great work Evan, thanks!
  • I was trying to find out some answers and I got it here. Thanks for this! I have the same error as I was upgrading it. I really dont have any idea what went wrong. I will try to configure it now.
  • I had the opposite issue - all instances within a cluster were reporting metrics, but I had nothing for one of the cluster nodes (the other was fine). Restarting the base monitor fixed it. Thanks!
    Jonathan Williams
    Database Administrator
    City of Spokane, WA
  • I've updated to 4.1 yesterday after updating SQL 2012 with SP2 on the monitoring server. Not getting any data in Genera, Buffer cache, Memory, Latches and Locks or host memory/CPU utilisation... But Top 10 waits and Top 10 queries seem to be working.

    Restarted the service, checked monitoring settings, restarted the monitoring server and still nothing.

    The website is on another machine and was updated to 4.1 at the same time... We have another SQL monitoring tool that is working fine and reporting all those numbers.

    Any ideas?
  • Hmmm. Installed SP2 and Cumulative Updates on SQL Server and after rebooting the server SQL Monitor picked it up and all numbers are showing again...
  • hayko1998hayko1998 Posts: 3 Bronze 1
    I am using Trial version of SQL Monitor 4.1.i can see only system databases. No user db visible. Any ideas why?
  • Is it possible that the user account you are using for monitoring the SQL Server instance only has permissions to view the system databases? Or some variation of permissions which does not give it full access?

    This forum post suggests a query that you can use to see what permissions a user account has on each database. It should help you see whether this is the problem

    http://stackoverflow.com/questions/7048 ... a-database
  • hayko1998hayko1998 Posts: 3 Bronze 1
    I am using windows Administrator account
  • A windows admin account doesn't necessarily have full permissions on a SQL Server instance, so it is still worth double checking.
  • Hi Red Gate
    I would like to know how to monitor and detected Deadlocks using SQL Monitor 4.1
Sign In or Register to comment.