TF30063: You are not authorized to access

hi 
i am getting following error 

We were unable to establish the connection because it is configured for user [email protected] but you attempted to connect using user SKaithi@xxx.com. To connect as a different user perform a Switch user operation. To connect with the configured identity just attempt the last operation again
 
not able link any database to source control
Tagged:

Answers

  • In this case we had to remove all traces of the user credentials in the registry to allow them to be refreshed. 

    These can be found under "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VSCommon\Licenses\17.0\VisualStudio"

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our 
    Help Center?

  • asharsashars Posts: 5 New member
    Hey skaithi,
    I've encountered the TF30063 error before, and it can be quite frustrating, but fear not, I've got a solution that might help you out. First off, it's crucial to ensure that your Visual Studio is running with the right permissions and identity. It appears that your configuration and connection details are mismatched.
    Here's what you can do:
    1. Registry Cleanup: As you've rightly pointed out, sometimes remnants of old credentials can lurk in the Windows Registry. Navigate to "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VSCommon\Licenses\17.0\VisualStudio" and remove any entries related to SKaithi or the problematic identity. This should help in refreshing your credentials.
    2. Switch User Operation: Follow the error's advice and perform a "Switch user operation" within Visual Studio. It might prompt you to re-enter the correct credentials, which should establish the right connection.
    3. Verify Configuration: Double-check your project settings and make sure they align with your source control provider settings. Any mismatch here can trigger such errors.
    4. Update Visual Studio: Ensure you have the latest updates for Visual Studio, as newer versions often come with bug fixes and improvements related to authentication.
    I hope this helps you resolve the issue and get back to linking databases to source control smoothly. 

Sign In or Register to comment.