How is SQL Prompt helping your team? Share your experience.

How do I turn off the SQL Prompt - Notifications popup window?

I just updated sql prompt.  Now I am getting this pop up window titled "SQL Prompt - Notifications".  It keeps telling me "Slow cache time detected".  How can I disable this warning or the popup all together.  
Tagged:

Answers

  • TomWTomW Cambridge Posts: 108 Gold 1
    edited July 26, 2019 8:48AM
    Hi @clayne100,

    Currently, the notifications such as "Slow cache time detected" can be dismissed by clicking the x icon and won't come back until the next SSMS session you launch.

    There's also currently a UserVoice request open for making the dismissal of notifications persist across sessions.
    https://redgate.uservoice.com/forums/94413-sql-prompt/suggestions/38116663-turn-off-notifications-such-as-slow-cached-time-d

    Kind Regards,

    Tom
    Software 
    Software Engineer for SQL Prompt
    Redgate Software
  • LivlaphluvLivlaphluv Posts: 4 New member
    @TomWalsh - this isn't exactly true. You can click the X to dismiss the current message but it may pop again during the same session. Since it is already slow, it is very frustrating to be slowed down even more because you have to stop and close the popup window.
  • TomWTomW Cambridge Posts: 108 Gold 1
    edited July 30, 2019 6:19AM
    Hi @Livlaphluv

    What version of SQL Prompt are you running? If you're using v9.5.9 or later, the dismissal of notifications should persist for the remainder of your SSMS session. If you're on that version or newer and that's not the case, please let us know and we'll see what we can do.

    Thanks,

    Tom
    Engineer, Team Prompt
    Software Engineer for SQL Prompt
    Redgate Software
  • clayne100clayne100 Posts: 6 Bronze 2
    It is working as designed. The red x will close it. Dismiss will make it go away for the balance of the session. I want it to go away forever. 
  • TomWTomW Cambridge Posts: 108 Gold 1
    Hi @clayne100,

    Currently, the notifications such as "Slow cache time detected" can be dismissed by clicking the x icon and won't come back until the next SSMS session you launch.

    There's also currently a UserVoice request open for making the dismissal of notifications persist across sessions. https://redgate.uservoice.com/forums/94413-sql-prompt/suggestions/38116663-turn-off-notifications-such-as-slow-cached-time-d

    Kind Regards,

    Tom
    Software Engineer, SQL Prompt
    Software Engineer for SQL Prompt
    Redgate Software
  • TomWTomW Cambridge Posts: 108 Gold 1
    Hi @clayne100,

    Currently, the notifications such as "Slow cache time detected" can be dismissed by clicking the x icon and won't come back until the next SSMS session you launch.

    There's also currently a UserVoice request open for making the dismissal of notifications persist across sessions. https://redgate.uservoice.com/forums/94413-sql-prompt/suggestions/38116663-turn-off-notifications-such-as-slow-cached-time-d

    Kind Regards,

    Tom
    Software Engineer, SQL Prompt
    Software Engineer for SQL Prompt
    Redgate Software
  • gvarol@corelogic.com[email protected] Posts: 90 Bronze 3
    edited July 31, 2019 1:43PM
    This has to go away. I am running version 9.5.12.10845 and I have to hit this dialog box hundreths times a day. We use ssms projects and have 8-10 different ssms windows open per user at any time, this is extremely unproductive. You are forcing us to uninstall the product.
  • Any update on this. This has been extremely time consuming for us.
  • TomWTomW Cambridge Posts: 108 Gold 1
    Hi @[email protected] 

    Adding the ability to dismiss a notification forever is currently top of our backlog and we're hoping to have it shipped in the next release.

    Thanks,

    Tom
    Team Prompt
    Software Engineer for SQL Prompt
    Redgate Software
  • OmerDogusOmerDogus Posts: 3 New member
    Dear Tom,

    Please removee\disable\fix it as sson as possible or we all will stop using SQL Prompt! It is not useful and interrupting our work everytime!

    Thanks
  • Can it be made than we can set a larger timeout if needed and it will not come up with a window in any case. Our servers are remote and metadata is fairly large, over few thousand tables plus views functions and more some having close to 1000 colums each and hundredths of tables with over 3000 partitions each, this is just one database, then there is synonyms etc to resolve. I dont even bother enabling check through linked server option anymore.
    I might be ok waiting 30 sec or so for it to refresh. A more precise refresh per server/db would be also helpful instead of refresh all. It would be nice to know when refresh is done and how long it took without a popup popup window.
    I usually have 4 or more seperate ssms running each to work on a different ssms project/solution. I am not sure how the caching works but it seem to be different ssms apps are not sharing the cache. Please consider also this scenario.
  • TomWTomW Cambridge Posts: 108 Gold 1
    Hi everyone,

    I'm pleased to say SQL Prompt 9.5.13 has just been released, which allows you to dismiss a notification forever. The next time you see "Slow cache time detected..." just click the 'x' and the product will never show that notification again.

    You can download that version here.

    Please get in touch if you have any other issues.

    Thanks

    Tom
    Team Prompt
    Software Engineer for SQL Prompt
    Redgate Software
  • PindiPindi Posts: 1 New member
    edited March 22, 2021 1:28AM
    I was using SSMS earlier and this popup notification kept popping up with the message "database is locked", twice in the same textbox.  After clicking on the X to dismiss it 4 times, and being very frustrated in moving about in SSMS with the very slow delays, and also seeing this article with the last response of saying to update to 9.5.13, I decided to try and close my SSMS, and then open it & try again to see the version  that we are using.  HOWEVER, after I clicked on the close X button to close my SSMS, right now it is still not closed and I encountered 5 popup messages with the same error message.  Every time I try to dismiss this popup, SSMS still does not close and the popup appears again.  If fact, after I dismiss the notification, my SSMS is frozen (I cannot click on anything else) until the popup goes away. 

    Finally, to close SSMS, I had to kill the task in Task Manager.  Very annoyed.  We are on version 10.2.1

    Is there a way to disable the actual popup notification, regardless of the error message, and view the error messages somewhere else, like in a Log table or file?

    I want to disable this notification permanently, just like the person above requested (and I think still did not get his/her question answered).  Please tell me how to disable this notification popup permanently, thank you.


  • YChenYChen Posts: 1 New member
    I am having the same issue now with SQL Prompt. I am on version 10.7.1. How to I make it stop permanently?
  • thomas12xthomas12x Posts: 2 New member
    I too get notifications of all sorts when opening SSMS (about current customer courses etc.) and would like to deactivate those permanently.
  • William_PGAWilliam_PGA Posts: 1 New member
    Please add a way to disable this for both users and non-users.  We share development server via a VM.   A user had to uninstall SQL Prompt because he did not wish to use SQL prompt and the popup appeared each time he did turned on SSMS.  Sometimes he was unable to turn off the popup as he was not logged in as a SQL prompt user.   Thank you. 
Sign In or Register to comment.