What are the challenges you face when working across database platforms? Take the survey
Options

IIS Express configuration file was not found

I updated to 10.1.5.1275.

Now I can't launch profiler from VS2015.

From log at C:\Users\rmaldonado\AppData\Local\Red Gate\ANTS Performance Profiler 10\antsprofiler-2c675553-e0ab-415b-996a-2c3a83bba368.log

11 Apr 2019 10:33:19.360 [14] ERROR RedGate.Profiler.Logic.Controllers.Setup.SetupController - Failed to generate history overview entry
System.NullReferenceException: Object reference not set to an instance of an object.
   at RedGate.Profiler.Logic.Controllers.Setup.ProjectType.AspIISESettingsController.GenerateProjectOverview(AspIISESettingsModel model)
   at RedGate.Profiler.Logic.Controllers.Setup.SetupController.GenerateHistoryOverviews(IEnumerable`1 history)
11 Apr 2019 10:33:19.365 [14] ERROR RedGate.Profiler.Logic.Controllers.Setup.SetupController - Failed to generate history overview entry
System.NullReferenceException: Object reference not set to an instance of an object.
   at RedGate.Profiler.Logic.Controllers.Setup.ProjectType.AspIISESettingsController.GenerateProjectOverview(AspIISESettingsModel model)
   at RedGate.Profiler.Logic.Controllers.Setup.SetupController.GenerateHistoryOverviews(IEnumerable`1 history)
11 Apr 2019 10:33:19.367 [14] ERROR RedGate.Profiler.Logic.Controllers.Setup.SetupController - Failed to generate history overview entry
System.NullReferenceException: Object reference not set to an instance of an object.
   at RedGate.Profiler.Logic.Controllers.Setup.ProjectType.AspIISESettingsController.GenerateProjectOverview(AspIISESettingsModel model)
   at RedGate.Profiler.Logic.Controllers.Setup.SetupController.GenerateHistoryOverviews(IEnumerable`1 history)
11 Apr 2019 10:33:19.370 [14] ERROR RedGate.Profiler.Logic.Controllers.Setup.SetupController - Failed to generate history overview entry
System.NullReferenceException: Object reference not set to an instance of an object.
   at RedGate.Profiler.Logic.Controllers.Setup.ProjectType.AspIISESettingsController.GenerateProjectOverview(AspIISESettingsModel model)
   at RedGate.Profiler.Logic.Controllers.Setup.SetupController.GenerateHistoryOverviews(IEnumerable`1 history)
11 Apr 2019 10:33:19.372 [14] ERROR RedGate.Profiler.Logic.Controllers.Setup.SetupController - Failed to generate history overview entry
System.NullReferenceException: Object reference not set to an instance of an object.
   at RedGate.Profiler.Logic.Controllers.Setup.ProjectType.AspIISESettingsController.GenerateProjectOverview(AspIISESettingsModel model)
   at RedGate.Profiler.Logic.Controllers.Setup.SetupController.GenerateHistoryOverviews(IEnumerable`1 history)
11 Apr 2019 10:33:19.374 [14] ERROR RedGate.Profiler.Logic.Controllers.Setup.SetupController - Failed to generate history overview entry
System.NullReferenceException: Object reference not set to an instance of an object.
   at RedGate.Profiler.Logic.Controllers.Setup.ProjectType.AspIISESettingsController.GenerateProjectOverview(AspIISESettingsModel model)
   at RedGate.Profiler.Logic.Controllers.Setup.SetupController.GenerateHistoryOverviews(IEnumerable`1 history)
11 Apr 2019 10:33:19.377 [14] ERROR RedGate.Profiler.Logic.Controllers.Setup.SetupController - Failed to generate history overview entry
System.NullReferenceException: Object reference not set to an instance of an object.
   at RedGate.Profiler.Logic.Controllers.Setup.ProjectType.AspIISESettingsController.GenerateProjectOverview(AspIISESettingsModel model)
   at RedGate.Profiler.Logic.Controllers.Setup.SetupController.GenerateHistoryOverviews(IEnumerable`1 history)
11 Apr 2019 10:33:19.406 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserProvider - Default browser's install name found. Value: 'ChromeHTML'.
11 Apr 2019 10:33:19.439 [14] INFO  RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - Starting trigger process C:\Program Files\Red Gate\ANTS Performance Profiler 10\RedGate.Profiler.Trigger_x86.exe
11 Apr 2019 10:33:19.456 [17] WARN  RedGate.Profiler.IISSupport.SharePointHelper - SharePoint version: none found (looking for 2013, 2010 or 2007 using registry keys)
11 Apr 2019 10:33:19.583 [13] WARN  RedGate.Profiler.Engine.Startup.IIS.IISUtilities - ENGINE - Guessing inetsrv path as C:\WINDOWS\system32\inetsrv
11 Apr 2019 10:33:19.790 [13] ERROR RedGate.Profiler.Engine.Startup.IIS.IIS7Utilities - The profiler tried to run "C:\WINDOWS\system32\inetsrv\appcmd.exe list apppools " but got the error: "<?xml version="1.0" encoding="UTF-8"?>

<appcmd>

    <ERROR message="Configuration error &#xD;&#xA;Filename: redirection.config&#xD;&#xA;Line Number: 0&#xD;&#xA;Description: Cannot read configuration file due to insufficient permissions&#xD;&#xA;." />

</appcmd>
" and exit code: 5
11 Apr 2019 10:33:19.795 [14] INFO  RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - Trigger process has connected
11 Apr 2019 10:33:19.797 [14] INFO  RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - A suitable trigger process is now available
11 Apr 2019 10:33:19.887 [13] ERROR RedGate.Profiler.Engine.Startup.IIS.IIS7Utilities - The profiler tried to run "C:\WINDOWS\system32\inetsrv\appcmd.exe list sites" but got the error: "<?xml version="1.0" encoding="UTF-8"?>

<appcmd>

    <ERROR message="Configuration error &#xD;&#xA;Filename: redirection.config&#xD;&#xA;Line Number: 0&#xD;&#xA;Description: Cannot read configuration file due to insufficient permissions&#xD;&#xA;." />

</appcmd>
" and exit code: 5
11 Apr 2019 10:33:19.975 [13] ERROR RedGate.Profiler.Engine.Startup.IIS.IIS7Utilities - The profiler tried to run "C:\WINDOWS\system32\inetsrv\appcmd.exe list apps" but got the error: "<?xml version="1.0" encoding="UTF-8"?>

<appcmd>

    <ERROR message="Configuration error &#xD;&#xA;Filename: redirection.config&#xD;&#xA;Line Number: 0&#xD;&#xA;Description: Cannot read configuration file due to insufficient permissions&#xD;&#xA;." />

</appcmd>
" and exit code: 5
Tagged:

Answers

  • Options
    Alex BAlex B Posts: 1,146 Diamond 4
    Hi @rickTechstyle,

    What version of ANTS Performance Profiler did you update from?  Have you previously changed the user that the service runs as?

    If you've updated from v9 and previously changed the service to run as an admin (or other) user, the service will have been changed to "ANTS Performance Prifler 10 Service" and so will not be set to run as the elevated user.

    Looking at the logging you've provided it seems this may be the issue as it appears to be having a permissions issue  trying to access the configuration file.

    In either case - please change the "ANTS Performance Prifler 10 Service" service to run as an elevated user and restart the UI and see if it is then able to work correctly.

    Kind regards,
    Alex
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
Sign In or Register to comment.