SQL Search 2 fails to uninstall

Hello,

I've recently upgraded one of our production PC's to SSMS 17.1 and I am having trouble getting SQL Search 2.4 to work with the program. I have tried uninstalling and reinstalling the SQL Search 2 program from Programs and Features and the program fails to uninstall, as after closing Programs and Features and reopening it, the SQL Search 2 program is still there. I have tried running the Windows Installer Cleanup Utility from Microsoft to try to remove SQL Search 2, but that failed as well. This PC is currently running Windows 10 Enterprise (version 1607). Please advise.
Tagged:

Comments

  • I am having the same issue Windows 10 1703.
  • Rob CRob C Posts: 419 Gold 2
    edited August 10, 2017 9:50AM
    Hi @Jonathon_R and @njzagaroli,

    I'm sorry to hear that you're experiencing this problem. Can you try uninstalling by running this powershell script and then sending me the resulting logfile? You may want to adjust the logfile path.

    This won't fix the problem, but hopefully it will give us more information as to what is going wrong during the uninstall process.
    $object = Get-WmiObject Win32_Product -Filter "Name='SQL Search 2'"
    $guid = $object.IdentifyingNumber
    Start-Process -FilePath "msiexec.exe" -ArgumentList "/X $guid /L*VX d:\uninstall\log.txt" -Wait -PassThru
    
    Software Engineer
    Redgate Software
  • ProgytechProgytech New YorkPosts: 5 New member
    Hi Rob C
    I am also having the same issue and when tried to remove the product using the power shell commands you posted I got some errors, so I decided to run the following command via a command prompt:

    msiexec.exe /X {A73DE592-3BE2-4085-A410-F137A2B0B623} /L*VX "J:\Downloads\Red-Gate Tools\SQLSearch2_uninstall_log.txt"

    Attached is the log file, hopefully you can figure out why the product is not being removed.
    I am running Windows 10 64bits version 1703 (OS Build 15063.540)
  • Jonathon_RJonathon_R Posts: 2 New member
    I was able to resolve this by taking the following steps:
    1. Running a system restore to back before I installed SQL Server Management Studio 17.1.
    2. Uninstalling SQL Search 2.
    3. Uninstalling SQL Server Management Studio 16.5.3.
    4. Installing SQL Server Management Studio 17.1
    5. Installing SQL Search 2.
    After I took the above steps, the SQL Search plugin appeared in the new version of SSMS. However, I would not consider the steps above a real resolution but more of a workaround, since this involves a lot of backtracking and extra time spent on an issue that should not exist.
  • ProgytechProgytech New YorkPosts: 5 New member
    Hi Jonathon_R
    Thanks for the feedback.
    Looking at your steps, I believe that in my case, before installing SSMS 17.1 I did the following:
    1. Removed SSMS 16.5.3
    2. Installed SSMS 17.1
    3. Try to install SQL Search 2.
    I believe that since SQL Search 2 was installed for SSMS 16.5.3, in my case removing SSMS 16.5.3 before uninstalling SQL Search 2 may be the reason why we are not able to uninstall SQL Search 2 to be reinstalled for SSMS 17.1.
    Unfortunately I cannot do a system restore as you did, so I will have to wait for Rob to come up with a force way to remove/reinstall SQL Search 2.
  • That's strange. The logfile says that the uninstall was successful. When you say it hasn't uninstalled it, do you mean that it's just a number of files that are remaining or is everything still in place, i.e. the program is still fully functional?

    Thanks.
    Software Engineer
    Redgate Software
  • ProgytechProgytech New YorkPosts: 5 New member
    Hi Rob,
    The program is not functional.
    • It will show in the "Apps & Features" as installed.
    • There are some assemblies in the "C:\Program Files (x86)\Red Gate\SQL Search 2" folder
    • When I try to re-install, it will not continue because it says that it is already installed.
    The solution may be to manually uninstall it, so it will allow to be re-installed.
    I am trying to remove the corrupted installation using Microsoft FixIt tool from this link:
    https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed
    I will post my finding if I am able to re-install SQL Search 2
  • ProgytechProgytech New YorkPosts: 5 New member
    Well, the FixIt tool was able to remove some registry keys and kind of clean up the corrupted installation.
    After rebooting, I tried to install SQL Search again and then got this error:
    ecl0w4tu9wr2.png

    At this point, I don't know what else to do to install this program.
  • ProgytechProgytech New YorkPosts: 5 New member
    Ha, unbelievable, I ran the setup again and this time it finished installation normally and guess what, it show up in MS SQL Server Management Studio version 17.2.

    Hope this work for others.
  • @Progytech That's great to hear! :)
    Software Engineer
    Redgate Software
  • I also cannot uninstall SQL Search 2, log attached. Running the script appears successful but SQL Search 2 still appears in the list of programs and also I couldn't install SQL Search 2 as it is listed as installed. I wanted to uninstall so I could install it for a newer version of SSMS. However, I've installed SQL Search 3 so its not a problem for me now, but v2 it is still listed as installed.
    log.txt 121.7K
  • anitaanita Posts: 1 New member
    I was finally able to uninstall this… Found out that I had Management Studio 2016 installed before I installed Management studio 17. I had to install Management Studio 2016 again and then used the add or remove programs to uninstall SQL Search 2, it then was removed from the list.
  • nxsornxsor Posts: 1 New member
    Came across this thread while trying to get SQL Search into SSMS 17 after originally having 18 installed with SQL Toolbelt. What anita said worked for me, I had to:
    • make sure SSMS 18 was installed
    • uninstall SQL Toolbelt
    • make sure SSMS 17 was installed
    • install SQL Toolbelt
    Posting this in case anyone else ends up in my weird situation and stumbles upon this thread.
Sign In or Register to comment.