Quoted_identifiers are ON, synch doesn't work

mrgrossmrgross Posts: 4
edited November 19, 2008 8:59AM in SQL Compare Previous Versions
newbie - be kind. :-)

I've got a sql2k db with quoted_ident=on yest the Compare scripts being generated are assuming it's OFF. Is there a swithc or soemthing I can throw to change that in Compare?

When I move to 2k5, it'll be different, but I can't switch it on the SQL box right now.

Comments

  • We did have a similar issue with QUOTED_IDENTIFIER in a previous version of SQL Compare (http://www.red-gate.com/messageboard/vi ... php?t=2182)

    However, this should have been fixed in version 7. Which version are you experiencing this issue with?
  • Version 7 - check. Every script output is double quoted.
  • I contacted the user through our support channels and he was able to resolve the issue while gathering information to send to me.

    It seemed that the comparison options had the Ignore 'SET QUOTED_IDENTIFIER and SET ANSI_NULLS statements' option ticked. Once this was unchecked the comparison ran as expected. If anyone else encounters this issue please try the resolution above. If this doesn't work and you require assistance please contact our support team at [email protected]
  • For clarification, the comparison always ran fine, it was just that the scripted output of actions to be taken were double quoted.

    The confusion comes in where an option to ignore certain directives in the comparison ALSO affects the output script, when you would expect the output script to be governed by the database version and not the comparison options.

    While I can see how the two work together, there shoudl either be options listed separately for the output script OR a better explanation of the effects of selecting/deselecting comparison options.

    Thanks for your help though!! Tech support is quite repsonsive and that is appreciated!
Sign In or Register to comment.