What are the challenges you face when working across database platforms? Take the survey
Options

<exclude>Role</exclude> not working

joemombergjoemomberg Posts: 8
edited May 26, 2016 3:20PM in SQL Compare 11
Hi
The following argument file for sqlcompare command line has the unexpected result of including the roles and schemas:
<?xml version="1.0" encoding="utf-8"?>
<commandline>
<server1>myserver</server1>
<db1>mydb</db1>
<scripts2>..Source</scripts2>
<exclude>Role</exclude>
<exclude>Schema</exclude>
<include>StoredProcedure</include>
<include>StoredProcedure:[sproc1]</include>
<include>StoredProcedure:[sproc2]</include>
<include>StoredProcedure:[sproc3]</include>
<include>StoredProcedure:[sproc4]</include>
<include>Table</include>
<include>Table:[tbl1]</include>
<include>Table:[tbl2]</include>
<include>Table:[tbl3]</include>
<include>Identical</include>
<options>iq</options>
</commandline>

Output:

Role db_securityadmin == ==
Role db_accessadmin == ==
Role db_denydatareader == ==
Role db_denydatawriter == ==
Role db_backupoperator == ==
Schema guest == ==
Schema dbo == ==
Schema INFORMATION_SCHEMA == ==
Schema db_ddladmin == ==
Schema db_backupoperator == ==
Schema db_datareader == ==
Schema sys == ==
Schema db_datawriter == ==
Schema db_denydatareader == ==
Schema db_denydatawriter == ==
Schema db_owner == ==
Schema db_accessadmin == ==
Schema db_securityadmin == ==

Any ideas? Thanks

Comments

  • Options
    Hey joemomberg,

    Thanks for contacting us and sorry you are having this issue!

    Did you have this xml script working previously?
    If you remove the <exclude> lines then does it still compare the roles?
    (it should only compare the items that are explicitly included unless you have the "IncludeDependencies" option on as well)
    What version of SQL Compare are you using?

    I will follow up with you via email for further troubleshooting.

    Kind Regards,
    Andrew Pierce
    Technical Sales Engineer
    Redgate Software
  • Options
    This is also an issue in the SQL Compare UI 11.5.2.509. When deselecting schemas, roles, and users, the script generation still deploys missing users and schemas, and then role memberships for users who are members of a role, at least in my case it does this for any role that has permissions on the object I'm deploying.
  • Options
    Hi
    I'm using 10.7.0.18.
    The script hasn't worked before and I've just tried with the exclude tags taken out. It's not too much of a problem, would just be nice to have a clean output.
    Thanks
    Joe
  • Options
    Hey Batts,

    By default the "include dependencies" option is enabled in the command line- in the GUI it will give you the opportunity to include or exclude dependencies.

    To Joe,

    I highly recommend you upgrade to v11 and retest - v11 installs alongside v10 so you can revert painlessly.

    Kind Regards,
    Andrew Pierce
    Technical Sales Engineer
    Redgate Software
  • Options
    Hi
    I'm working on sweet talking our procurement folk into an upgrade to v11.
    I can see the incd option but there doesn't appear to be an exclude dependency option though?
    Thanks
    Joe
  • Options
    krshortkrshort Posts: 12 Bronze 1
    I'm having the same difficulties, and I believe my problem may be related to the default behavior of the command line. How do I Exclude Dependencies using command line?

    Regards,
    Kevin
Sign In or Register to comment.