What are the challenges you face when working across database platforms? Take the survey
Options

"Connections to ignore" does not work for linked server

edockxedockx Posts: 9
edited October 10, 2008 7:09AM in SQL Prompt Previous Versions
I've added the linked server and "all databases" to be ignored, but the connect dialogue keeps appearing.

SQL Prompt version 3.9.0.43

Comments

  • Options
    I have seen this issue occur before due to differences in case. Currently SQL Prompt is case sensitive when it comes to adding to the 'Connections to Ignore'. Could you make sure that the entry in the 'Connections to Ignore' settings is written exactly the same (including case) as the server mentioned in the Authentication pop-up?

    If this doesn't work could you give me a little more information about the Linked server? Is it another SQL Server and is the 'SQL Server' radio button checked in the linked server's general properties?
  • Options
    The name is the IP address, this is the CREATE script :
    /****** Object:  LinkedServer [192.9.200.10]    Script Date: 10/02/2008 15:15:21 ******/
    EXEC master.dbo.sp_addlinkedserver @server = N'192.9.200.10', @srvproduct=N'SQL Server'
    
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'collation compatible', @optvalue=N'false'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'data access', @optvalue=N'true'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'dist', @optvalue=N'false'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'pub', @optvalue=N'false'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'rpc', @optvalue=N'false'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'rpc out', @optvalue=N'false'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'sub', @optvalue=N'false'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'connect timeout', @optvalue=N'0'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'collation name', @optvalue=null
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'lazy schema validation', @optvalue=N'false'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'query timeout', @optvalue=N'0'
    GO
    EXEC master.dbo.sp_serveroption @server=N'192.9.200.10', @optname=N'use remote collation', @optvalue=N'true'
    

    I reference the linked server as follows:
    ...
    inner join [192.9.200.10].[Verso].[dbo].[TableName]
    ...
    
  • Options
    I've created a linked server using exactly the same script as you provided (adding an IP address of a SQL Server on my network). However, I can't recreate your issue. When I first referenced the linked server it asked for authentication and I chose 'Do not Connect' and that was it no other authentication dialogs appeared. I also went through the process again and added the server to the 'Connection to Ignore' and it functioned as expected. Where in the script does this issue occur? When you open a clean query window and type a simple statement incorporating the linked server do you still experience the issue? Or does it seem to occur when working with a large complex script? Which version of SQL Server are the two servers? Are there any other patterns that you have seen that relate to this issue?
Sign In or Register to comment.