What are the challenges you face when working across database platforms? Take the survey
Options

SQLBackup v5 "The database file is locked" - SQLiteException

WTSWTS Posts: 4
edited June 24, 2007 8:34PM in SQL Backup Previous Versions
Hi there:

This issue has been passed around by RedGate tech support for three days and no resolution has been found so far.
Several people took a stab at this including:

Brian Donahue, Chris Auckland, Ben Pinchen, and a fourth guy who is trying right now - didn't get his name.

Executive Summary:
Upgraded from v4 to v5.0 on Server 1, activation had to be done through email, fine with that. Backups run smoothly, no issue. Upgraded Server2 the next day because it needed to be rebooted (off-hours) for MDAC 2.8 installation, activation works nicely. Start the GUI on Server2, it tries to connect to Server2 - hopefully picking up the settings and jobs of v4 - it freezes up and keeps spinning its green wheel, no backups run that night!
After several attempts, including restarting the Service, deleting the database file, the application cache, etc., I get an error message and the GUI quits.

Details:
6/19
"I will be upgrading our second server tomorrow. It needs a reboot because of the MDAC 2.8 and .Net 2.0 Installs that were required by SQLBackup, and that won't happen till after hours."
6/20
"Hi Chris: I finished the installation on the second server and was able to activate it over the internet; however it would not load the Ver. 4 settings. It shows under the list of Servers (local) and its spinning green wheel keeps spinning non-stop - for a very long time! I tried to Delete it and re-import but to no avail. I tried to import it by name, then as simply (local) but neither worked. I was able to import the server settings of the other server I installed yesterday and they work fine from this interface.

After several attempts I get the following error message:
SQLBackup v5

The database file is locked
database is locked
WorkerExecutionException

at RedGate.SQLBackup.Engine.ConfigurableThreadPool._1(Exception )
at RedGate.SQLBackup.Engine.ConfigurableThreadPool._1._2()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
SQLiteException

The database file is locked
database is locked

at System.Data.SQLite.SQLite3.Prepare(String strSql, SQLiteStatement previous, String& strRemain)
at System.Data.SQLite.SQLiteCommand.BuildNextCommand()
at System.Data.SQLite.SQLiteCommand.GetStatement(Int32 index)
at System.Data.SQLite.SQLiteCommand.ExecuteNonQuery()
at System.Data.SQLite.SQLiteConnection.Open()
at _6._1(SqlConnection , UpdateRequest , _5 )
at _6._1(SqlConnection , UpdateRequest , _5 , Boolean )
at _6._2(Object )

After that I uninstalled it from the Server and reinstalled it with Local System Account as the startup account for the service. Same issue."

Another approach:
6/21
"Can you restart the SQL Backup Agent service on the server you're trying to connect to (using the local server's Services control panel), and then launch SQL Backup? Also, do you happen to know if this happens on multiple SQL Backup consoles accessing the same server?"

Restarted the Service and tried to access it from Server1, the GUI freezes cold, I had to Kill the app using Task Manager.

Any help with this would be greatly appreciated.
Thanks.

P.S.: You can email me directly at akzebdi@wts.com
Cheers.

Comments

  • Options
    I believe you are still working on this issue (#4125) with Brian in the support team.

    I would like to assure you that the support team have access to the full resources of Red Gate, including assistance from the testers and developers if needed, so you can be confident that you are already dealing with the best people to find you a resolution.
    Chris
Sign In or Register to comment.