Log shipping error "Folder Does not exist" for shared pathh

raj_technomanraj_technoman Posts: 10
edited March 14, 2014 8:31AM in SQL Backup Previous Versions
Hi There,

I try to set log shipping and on third step of my log shipping ,
when I try to input any shared path in "Network Share" text box.
It always say "Folder Does not exist" .

That folder has read/write permission for "Everyone" and folder is browse from "Network Share"'s browse button only.

In Red Gate it said "Folder Does not exist" but same folder is valid folder from "SQL Log Shipping".

Please reply us ASAP.

Thanks,
Rajendra

Comments

  • Eddie DEddie D Posts: 1,406 Rose Gold 2
    Thank you for your forum post.

    Despite and I quote:
    That folder has read/write permission for "Everyone" and folder is browse from "Network Share"'s browse button only.

    The error message does indicate that the account given to the SQL Backup Agent does not have security permissions to the network share folder.

    Run the following query to ensure that the account has sufficient given to the SQL Backup Agent has permissions on the network share:
    EXECUTE master..sqbutility 999, 'RWE', '<network location>'
    

    Replace <network location> with the unc path to the network share.

    If this is successful and the SQL Backup Agent service has read (R), write (W), and execute (E) permissions, the query will return:

    <SQBUTILITYRESULT>:1:

    If there is a problem, the query will return a value of 0, followed by a message, for example:

    <SQBUTILITYRESULT>:0:Folder does not exist :
    <network location>

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
  • Hi Eddie,
    Apologies for very late reply.

    Please find my SP and execution result as per below,

    SP:
    EXECUTE master..sqbutility 999, 'RWE', '\\Rym-db-svr\RedGateLogShipping'

    Result:
    <SQBUTILITYRESULT>:1:

    So means that I gave correct path and user has correct permission also.

    But Logshipping’s step 3 still say that “Folder Does not existâ€
  • chfoxchfox Posts: 2 New member
    *bump*

    I am running into this same issue.

    When I run:
    EXECUTE master..sqbutility 999, 'RWE', '&lt;network location&gt;'

    it returns:
    <SQBUTILITYRESULT>:1:  

    But when I try to set the file share for log shipping I get the "Folder does not exist" error
  • chfoxchfox Posts: 2 New member
    Bah, never mind!

    It was a permission issue, just like you said.

    "Dear Person Reading This in the Future,
    Make sure to check both the source and destination servers for permission issues."
Sign In or Register to comment.