What are the challenges you face when working across database platforms? Take the survey
Options

SQL Promt will not work on table named "Item"

wilfredwilfred Posts: 4
edited May 18, 2010 10:51AM in SQL Prompt Previous Versions
We have a database with a table named "Item". SQL Promt will just not work for that table.
If I type:
select * from Item where Item.
it will not list any of the fields that belong to te table named Item.
In fact, when I type the period symbol it will translate "Item." into "ITEMINFO." that is another table in the database.

The table named Item is used in many relations in our database so this is very annoying.

Can it be that SQL Promt think that "Item" is a reserved keyword?

Comments

  • Options
    Have you tried wrapping the the table name with square brackets, e.g. [Item]?
  • Options
    I just tried that and experience the same issue.
    I type select * from [Item] where [Item]
    and when I hit period it will translate [Item]. into [ITEMINFO].
    and when I correct the line to [Item]. it wil not give me any suggestions for table [Item]

    Thanks for suggesting this. It now looks like a bug to me.
  • Options
    Created [Item] table in a different database. Everything working OK.

    Must be something with the database or the definition of the [Item] table. Any suggestions?
Sign In or Register to comment.