Missing SQLBackupAgent group entry in Cluster Admin

ChrisAVWoodChrisAVWood Posts: 361
edited April 12, 2010 9:38AM in SQL Backup Previous Versions
Hi,

We have discovered that we have an x64 clustered server, now running SQLBackup 6.4, that does not have a group entry under SQL Group in Cluster Admin. We just upgraded from 6.3 to 6.4 and discovered we didn't have the entry as we tried to remove the WOW3264Node from the Registry Replication tab.

Comparing the actual registry on this cluster to another cluster that has the entry in Cluster Admin is that under the HKLM\System\CurrentControlSet\Services\SQLBackupAgent the key Start is set to 2 when on a good cluster it is set to 3.

Based on this do I just have to change the registry key from 2 to 3 and it will appear in Cluster Admin?

Thanks

Chris
English DBA living in CANADA

Comments

  • Eddie DEddie D Posts: 1,643 Rose Gold 5
    Thank you for your post into the forum.

    How strange, was there a SQL Backup Resouirce in the Cluster Admin before you upgraded from V6.3 to V6.4?

    Are the V6.4 server components installed successfully onto both or nodes of the cluster?

    In the registry, is there an IsClustered key in the following folder?
    HKLM\SOFTWARE\Wow6432Node\Red Gate\SQL Backup\InstalledInstances\<Instance Name>

    The IsClustered key is a DWORD type and should be a value of 1. If the answer is yes the IsClustered key exists and the Server Componets (ie SQL Backup Agent Service)are present or have been installed on other node or nodes, you could trying manually creating the SQL Backup resource in the cluster admin as follows:
      Right-click on the SQL Server group, click New, and then click Resource. On the New Resource page, enter the following details:Name: SQL Backup Agent - <instance> Description: Optional. Resource type: Generic Service Group: The group to which the SQL Server instance is registered. On the Possible Owners page, ensure that the nodes listed match those that the SQL Server instance can run on. On the Dependencies page, you are recommended to add the SQL Server instance and the physical disk. On the Generic Service Parameters page, ensure the Service name is listed as SQLBackupAgent for the default instance, or SQLBackupAgent_<instance> for a named instance. For a named SQL Server instance, enter the Start parameters as-i <instance> On the Registry Replication page, add the following registry keys (do not include the HKEY_LOCAL_MACHINE prefix): For 32-bit servers: SOFTWARE\Red Gate\SQL Backup\BackupSettings\<instance> SOFTWARE\Red Gate\SQL Backup\BackupSettingsGlobal\<instance> For 64-bit servers: SOFTWARE\Wow6432Node\Red Gate\SQL Backup\BackupSettings\<instance SOFTWARE\Wow6432Node\Red Gate\SQL Backup\BackupSettingsGlobal\<instance> Bring the Clustered Resource online.

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
  • Thanks Eddie,

    Looking at the HKLM\SOFTWARE\Wow6432Node\Red Gate\SQL Backup\InstalledInstances I cannot find any IsClustered key. I also checked one of our successfully upgraded clustered server and found the IsClustered key under HKLM\SOFTWARE\Red Gate\InstalledInstances\(LOCAL) as IsCluster.

    Of course my problem server is the production one so I cannot try this for more than a week.

    I will add the IsCluster key and see what happens.

    Chris
    English DBA living in CANADA
  • added the IsCluster registry key but that didn't fix it. I had the add the SQLBackupAgent as a resource in Cluster admin before it worked. The registry entry HKLM\Software\Red Gate\SQL Backup\BackupSettings doesn't exist when I see it on others.

    regardless 6.4 is working on this server.

    Chris
    English DBA living in CANADA
Sign In or Register to comment.